安装RabbitMQ时提示错误:error: Failed dependencies: socat is needed by rabbitmq-server的解决方法

栏目:Linux 作者:小天 点击: 9,827 次

安装RabbitMQ-Server时提示以下错错误:
warning: rabbitmq-server-3.6.5-1.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 6026dfca: NOKEY
error: Failed dependencies:
socat is needed by rabbitmq-server-3.6.5-1.noarch

原因:rabbitmq-server-3.6.5-1.noarch需要socat的组件的支持。

解决方法:我们执行安装socat命令安装即可:

yum install socat



------====== 本站公告 ======------
欢迎使用趣域网域名百科,我们将长期提供域名使用相关知识和投资域名的方法和技巧;并提供主机、服务器的解决问题和网站运营方法。